Announcement

Collapse

TGC Tour - Congratulations!

Congrats to @strider33 winning the TGC 2016/2017 Winter Tour - Tournament of Champions!

Join this weeks TGC 2016/2017 Winter Tour - Sony Open Hawaii with 2 rounds at The Baltasar, Spingfiled NJ, Baltasar Tees 6652yds : http://golfsimulatorforum.com/forum/...ny-open-hawaii
See more
See less

Please help with my hardware and or software issues re: TGC

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help with my hardware and or software issues re: TGC

    First off- TGC support is fantastic! I have also opened a ticket with them as I'm confident they can help, but I'm posting this up here as well in case anyone else is running into the same type of issue I'm having. In a nutshell- when I first start using my sim for the day, I have a hard time just starting everything up and getting the game running. I've run into all kinds of different issues with connectivity starting up for the day but generally after I get it running it's good to go for the rest of the time I'm using it, until it is stored again. I'll try to provide as much diagnosis detail as possible.

    Set up data- I'm running an ASUS ROG gaming laptop on Windows 10. I have a GC2A, and it is connected with Protee 3.10D, the most recent version. The laptop has an internal Bluetooth adapter, and everything seems to work great in terms of pairing, though I haven't figured out how to get the laptop to the point where I enter in 0000 as the passcode. The laptop provides a random code that asks if it matches the GC2, and when I hit "yes" it pairs.

    Generally speaking, I need to reboot my PC to be able to run TGC after the last session, otherwise my shot data doesn't register in TGC. I THINK it is because I need to restart the server, and any time I try "stop server" I get the spinning wheel of no progress. When I restart the PC, I boot Protee, then GSX, then I slide the switch to "On," boot up TGC, start server, and start game. If I don't restart the PC, generally TGC doesn't show the shots, even if GSX does.

    Yesterday, that process didn't work, and I needed to re-pair my GC2 to get it to work. After that, everything worked great up until I lost my internet connection, at which point I also lost shot registering on TGC. I had to reboot, re-pair, and then it started working again.

    Has anyone else run into anything at all like this? What was your resolution? Any help would be much appreciated.

    Thanks,

    Bob


  • #2
    BM11 i would back away from any kind of internal bluetooth first of all and move to an extension cable and an Asus bluetooth dongle, I would also hardwire your internet if at all possible.

    Comment


    • #3
      Originally posted by aeroburner View Post
      BM11 i would back away from any kind of internal bluetooth first of all and move to an extension cable and an Asus bluetooth dongle, I would also hardwire your internet if at all possible.
      You are more knowledgeable than I when it comes to this type of thing, so perhaps you can help me understand- why would an external Bluetooth solve any of my problems? My computer seems to find and pair to my GC2 and keep the connection without issue, it seems to be the software or a setting that's messed up in this case.

      Comment


      • Stingreye
        Stingreye commented
        Editing a comment
        From what I read about some blue tooth adapters are considered to be more stable than others. Some also work better over longer distances. The adapters that are recommended are relatively cheap. So my guess is that if people have trouble with a built in adapter they opt for the recommended Bluetooth adapter on a USB extension cable.

      • mthunt
        mthunt commented
        Editing a comment
        Aero is right. You need a good Bluetooth dongle and USB extension. Run the wire /dongle pretty close to the GC2. The closer the better. Other Bluetooth devices seem to cause havoc as well.

    • #4
      Also, is this the one? https://www.amazon.com/ASUS-USB-Adap.../dp/B00DJ83070

      Comment


      • aeroburner
        aeroburner commented
        Editing a comment
        yes thats the adapter

      • aeroburner
        aeroburner commented
        Editing a comment
        yes thats the adapter

    • #5
      I can't remember if it was you or another user but turn OFF power savings for your Bluetooth adapter. Someone here posted a video how to do it on here a few weeks ago.

      Ever since I updated to 3.10D anytime gsx registers a shot, the shot shows in TGC. So if you are getting a shot in gsx but not TGC, that seems odd. Check the pro tee interface for any errors.

      Good luck!

      Comment


      • #6
        I ordered the Bluetooth adapter and extension, I'm willing to give it a try.

        The issue seems to be with keeping the GC2 paired- most likely another Windows 10 issue. This morning when I went out to play I had to delete and re-pair my GC2 to be able to get GSX to link up.

        Comment


        • #7
          Try following this link's directions on his problems.... since you are using a laptop, it might work:
          http://golfsimulatorforum.com/forum/...necting-solved

          Comment


          • #8
            Originally posted by Stingreye View Post
            Try following this link's directions on his problems.... since you are using a laptop, it might work:
            http://golfsimulatorforum.com/forum/...necting-solved
            90% sure I did that already but I will do so to make sure, thanks!

            What I'm having a hard time grasping is why buying an ASUS Bluetooth adapter is a better solution than using the Bluetooth connection inside of my ASUS laptop... but I'm going to give it a try.

            Comment


            • #9
              there is a thread on this if i can find it i will attach

              Comment


              • #10
                Update- USB Bluetooth dongle did not help but added additional issues. It turns out that the onboard Bluetooth is much stronger, so when using the plug in dongle I'd have issues where me (lefty) would hit and the shot either wouldn't register until I moved the GC2 closer or it registered super slow. It also wiped out all of the internal drivers which had to all be reloaded before I could get it up and running. Swapped back to internal Bluetooth and the new issues went away.

                I did find this out- while "stop server" doesn't work in game, task manger will find "server" with a TGC icon on it and shut it down. This allows me to hook up without rebooting- I just need to make sure I end the server process before starting a fresh game the next day.

                Another thing I'm finding though- if a popup shows up while playing, I can't get the screen back to 1920x1090. It defaults to 640x480 which essentially shows up as a postage stamp on my screen. Does anyone have a work around for that?

                Comment


                • #11
                  I assume you have a gc2. The things needs a good Bluetooth and it needs to be close. I bought a trednet exnteded range dongle and a extension cord. I put it in the room and it works great. The dongle is crucile. A. GC2 is 7 grand, TGC is a grand. Buy a good one to improve the experience. The closer the better. Mine is 6 feet but its a great dongle.

                  Why would you need to stop the server?

                  Your last point. Are you running full screen? Bad idea with TGC. Run it windowed with the task bar auto minimized. It's the best way.

                  Comment


                  • #12
                    Originally posted by mthunt View Post
                    I assume you have a gc2. The things needs a good Bluetooth and it needs to be close. I bought a trednet exnteded range dongle and a extension cord. I put it in the room and it works great. The dongle is crucile. A. GC2 is 7 grand, TGC is a grand. Buy a good one to improve the experience. The closer the better. Mine is 6 feet but its a great dongle.

                    Why would you need to stop the server?

                    Your last point. Are you running full screen? Bad idea with TGC. Run it windowed with the task bar auto minimized. It's the best way.
                    1: I bought the ASUS Bluetooth dongle recommended in a number of threads here, and lost considerable connection power compared to my internal. My internal Bluetooth never has connection issues, always stays connected, and has no delay. The issue that I'm running into is that getting it hooked up for the first time of the day is a bear, and seems to be a TGC issue. Based on my success with the internal Bluetooth and my failure with the external, I'm feeling a bit "once bitten twice shy" on trying another option, especially since fixing the wiped out internal Bluetooth was a huge process after installing the external adapter.

                    2: This is the fix for the issue I have been having- even if both Protee and GSX are running and register the shot from the GC2, TGC doesn't acknowledge the shot unless I start the server fresh from the last time I played. For example- I play Thursday and put everything away. Sunday I go out to play, the GC2 connects to my laptop via Bluetooth no problem, connects in Protee and GSX, but then I swing a club the ball doesn't move in TGC. Protee and GSX both show the shot but TGC does not. If I stop the server and reconnect, everything works until the next time I go to play where I have to go through the same process.

                    3. I'm running full screen, yes. I have something funky going with my graphics settings that I can't figure out how to change though, which is why I'm running it full screen. Maybe someone could walk me through a fix? My preferred resolution is 1920x1080 to match my projector. When I first start up TGC the window and some of my background on my PC show up in crappy 640x480 resolution. If I choose 1920x1080 in full screen, I get nice HD graphics. If I choose 1920x1080 windowed, I get really crappy, blown up 640x480 graphics. This was not always the case and is the result of some setting that got toggled, if anyone could walk me through a fix it would be much appreciated.




                    I really enjoy sim golf and so do my friends, but the issues I have been running into with getting TGC to work have got me considering buying FSX at this point, as my experiences with FR1 with one exception have been simply "boot up the software while the GC2 is running and go."

                    Thanks,

                    Bob

                    Comment


                    • #13
                      ^^ interesting.

                      Are your USB ports USB 2.0 or USB 3.0? If 3.0, ignore what I am about to say because it should have plenty of power. If 2.0, I ran into an issue with a media center computer I setup. The remote control would only work 2-3 feet from the dongle. I returned it, second didn't work any better. Turned out, despite supposedly being a robust motherboard, the USB ports were underpowered. I had to buy a USB hub with an external power adapter and then it worked perfectly over 30 feet. This problem was with a USB 2.0 port. If your port is 3.0, I seriously doubt it would have power problems.

                      Sorry to hear about all your trouble! I have fr1 too but TGC has been much more enjoyable for me. I haven't had all the disconnects people have had or Bluetooth issues since the first week I had it (knock on wood).

                      Comment


                      • #14
                        It looks like I have USB 3.0 ports.

                        Why is everyone so adamant that I need an external Bluetooth adapter if the internal one that I have connects so strongly? What am I missing?

                        Comment


                        • #15
                          ProTeeGolfOnline With protee back from vacation have you had them mobile connect with support on these exact issues has a ticket been pulled

                          Comment

                          Working...
                          X