Announcement

Collapse
No announcement yet.

TGC2019 won’t work right

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TGC2019 won’t work right

    Hey guys looking for some help here. I’ve had TGC2019 for a while now. However, my skytrak won’t let me play anything. I’ve tried reinstalling the program, but that hasn’t worked. My skytrak app works and I can hit golf balls on the driving range all day. When I exit out of the skytrak range and load up tgc19, I get two green lights and the top red light. Anyone else having the same issue and how did you resolve it?

  • #2
    Having exactly the same problem. Tried a full re-install but no luck. Searching the web to see if anyone has had better luck. The range on Skytrak 5.0 works but not TGC 2019.

    Comment


    • #3
      I think I found a solution.

      Right click the "TGC Skytrak Interface" icon and "Run as Administrator" and when I went through the steps to start TGC 2019 I got the proper green lights on my Skytrak OG and the laser dot on the mat. Not sure why that worked as I am the sole user of my computer and therefore run it as an administrator account but this step seemed to solve the problem. The good thing is the administrator setting seems to stick and you only have to do it once. The next time you start the program you can just click the icon normally.

      Comment


      • #4
        Thanks for posting. I've been having the same issues with my Skytrak and grow more frustrated with each time for one issue or another. I was about to give up but found your post and tried it. Worked for me as well! As someone who works in software, this makes no sense to me but it did work so I'm just going to go with it. Thanks Dwayne28!

        Comment

        Working...
        X