TGC Tour - Congratulations!

Congrats to @Wiscogolfnut (NET) and @Marc Andre (GROSS) winning the TGC 2019 SUMMER TOUR - 3M Open !

Join this weeks TGC 2019 SUMMER TOUR - John Deere Classic with 2 rounds at The Merion East Ardmore, PA (ProTee - Middle) :
See more
See less

Foresight GC2 - Input Disconnected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Foresight GC2 - Input Disconnected

    I can’t get the input to show connected.

    Bluetooth wasn’t working (my asus on the computer couldn’t find the foresight Bluetooth) so I went ahead and hard wire connected the launcher to the computer.

    But it still shows input not connected.

    Any ideas?


  • #2
    What software you trying to run?

    edit: nm, I see you have half a dozen threads going on the same problem. Make one thread and provide all the info in one place and you'll get better responses.

    tgc doesn't work hardwired. Need Bluetooth.
    Last edited by FaultyClubs; 01-10-2019, 02:30 AM.


    • #3
      Thanks. Sorry each time it’s been a whole other avenue so I thought a new thread was better.

      Thanks for letting me know about the hard wiring. I run The Golf Club. the problem then seems to be that the computer Bluetooth (Asus) is not finding the Foresight. The Foresight is not listed in the list of Bluetooth devices and I have no idea why. I’m lost at the moment...


      • #4
        What OS?
        Have you tried Bluetooth to a iPad or iPhone to see if you see the GC2? I had the Bluetooth board go out on mine and this what FS would have you try.
        Start over with sticky on setting up the GC2 to Bluetooth and TGC
        Let us know how it goes we can help you get it working.


        • #5
          Does the foresight Bluetooth work? Maybe use your phone to verify. How far away is the gc2? Some people find the bluetooth unreliable if more than a few feet away.

          if foresight bluetooth works then try rebooting your computer.

          if still not finding the foresight bt then windows has a bluetooth troubleshooter (in control panel) you can run.


          • #6
            So the Foresight Bluetooth isn’t showing up on the device manager.

            The device is just a couple of feet away, where it always is and has worked in the past.

            how would I use my phone to verify?



            • #7
              Update - so my iPhone does detect the foresight. So need to figure out why the computer doesn’t. They’re super close. And it says the Asus Bluetooth is working.


              • #8
                Mxwoodman the computer is Windows 10


                • #9
                  Another windows 10 issue. So glad I downgraded. My windows 10 didn’t work either.


                  • #10
                    I have windows 10 and a couple of updates over the last few months have disconnected my GC2 from my Bluetooth. I just had to add it to my computer bluetooth again before launching the apps. Also note- one update changed my com port. Other than that, my windows 10 has been working fine.


                    • orangeman
                      orangeman commented
                      Editing a comment
                      +1 for checking ports. This same thing happened to me. Once I changed the ports in GSX to match, all was well and still working solidly.

                  • #11
                    On SGX it says com port 4 which is same as always I think? Is there another com port to check? Like on the computer?

                    In any event, I still have the main problem I believe which is the fact that my computer (via the Asus bluetooth) is not finding the GC2 bluetooth. No idea why...
                    Last edited by GarryB58; 01-10-2019, 12:52 PM.


                    • sherrow70
                      sherrow70 commented
                      Editing a comment
                      Yes it could of changed ports on computer this has happened to me. Google how to view your bluetooth ports in windows 10. I believe it is outgoing that needs to be the same as SGX. Also as Godfather below said I have had to do that as well.

                    • orangeman
                      orangeman commented
                      Editing a comment
                      You need to check the bluetooth ports in Windows. That's where they have likely changed. I'm pretty sure you can check with Device Manager.

                  • #12
                    Every so often, I have this issue. I delete the Bluetooth, restart the GC2, and reconnect Bluetooth. I’m not sure why it happens, but I’m always able to get it to work again by disconnecting and again pairing the GC2.


                    • #13
                      Do this -
                      bluetooth troubleshooter (in control panel)
                      Yes every time you setup a device it will use the next com port - the other times you tried it may have used a new com port - once in use it won't reuse it again and the next time when connecting a new device but it will use the next port.


                      • #14
                        It works! Thanks everyone for all of the help. You guys were right that it was the com port. I found a video online showing how to add a com port on windows 10 and followed it. By clicking “add” it found the Foresight and then it asked me to click to install it so walked me right through. It connected immediately.

                        no way I could have figured that out without you experts. I really appreciate it!