Announcement

Collapse

TGC Tour - Congratulations!

Congrats to @Jard (NET) and @ecarl97 & @Randy (GROSS) winning the TGC 2018 SUMMER TOUR - TGC Championship !

Join this weeks TGC 2018 SUMMER TOUR - Tour Championship with 3 rounds at East Lake Simulator #1 : https://golfsimulatorforum.com/forum...r-championship
See more
See less

TGC - Searched courses won't load/play?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TGC - Searched courses won't load/play?

    I just received my Skytrak and TGC, first time using so this may be a newbie question.

    I searched for courses, i.e. "Pebble", and try to select Pebble Beach ProTee, or any other version that pops up. I simply hear a noise, and it won't advance to the game with the course selected.

    Do I have to enable something? I was only able to play one of the official courses. It seemed like no course I chose in the search menu would let me play.

  • #2
    Dang, that's brutal. Are you getting the loading icon in the lower right hand corner of your screen and also being patient? Sometimes it will take mine a minute or more to load. Also, what lighting configuration do you have from top to bottom for the three lights on your SkyTrak while trying to load?

    Comment


    • #3
      I was worried about that as well when I started. As FirGir mentioned, after you chose a course, see if that loading icon is blinking in the lower right hand corner. It can be extremely slow at times, especially when you are ready to play! I've had to wait up to 5 minutes before with a brand new i7 computer and 30 mb wifi. Once the game loads, there isn't any in game delays though.

      Comment


      • #4
        Thank you guys for the responses!

        I did have that rotating loading icon in the bottom right. What exactly does that mean?

        I searched for the courses, i.e. Pebble, and it loaded a list. I then went inside for a few minutes (prob 3 minutes or so) and came back out, and then tried clicking but it still wouldn't work. I guess I can try giving it even longer than that, seems very bizarre!!

        Comment


        • FirGir
          FirGir commented
          Editing a comment
          That icon means it's loading and, yeah, it can take a few minutes but shouldn't take forever. Any chance your computer doesn't have enough horsepower? Check in with the SkyGolf Live Chat Support team before it drives you nuts - they've always been very helpful for me.

        • ProTee United
          ProTee United commented
          Editing a comment
          Network, or firewall issues. Also you antivirus program could be blocking TGC from reaching the servers. Check firewall first. server.exe and golf.exe should have full access: https://computing.which.co.uk/hc/en-...ndows-Firewall

      • #5
        I'm thinking your silence means you got this resolved?! If so, what fixed it? Did you get the lobster roll at the turn at Pebble?

        Comment

        Working...
        X