Announcement

Collapse

TGC Tour - Congratulations!

Congrats to @orkie (NET) and @Joe_S (GROSS) winning the TGC1 2020 SUMMER TOUR - WGC-FedEx St. Jude!

Join this weeks TGC1 2020 SUMMER TOUR - PGA Championship Tournament with 3 rounds at Pine Valley (Protee Blue Tees): https://golfsimulatorforum.com/forum...hip#post281617
See more
See less

Brand new Skytrak won't charge at all

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Brand new Skytrak won't charge at all

    I just got my Skytrak 2 days ago. I followed the instructions to withhold from using it until after an initial 6-hour charge, and in fact I charged it overnight for 12 hours using the included cable and charging block plugged into a wall outlet. I turned it on the next day and after connecting to the Skytrak app on my iPad, it read only 47%. I used it for 45m or so, and once it got down to 32% I turned it off and plugged it back in for 5 hours. Light turned yellow light it should, but stayed yellow even after 5 hours. Turning it on again showed 32% still -- it didn't take any charge at all after the 5 hours. So I tried an overnight charge again last night. When I woke up today the yellow light was now flashing. And it's still at 32% after an overnight charge.

    I've tried using different cables and charging blocks, and none of them will add charge to the Skytrak. I called Skytrak and they are preparing a return/exchange, saying they have seen this before with older units but not brand-new ones. I figured I'd try here to see if anyone has any ideas before I go ahead with the return/exchange.

    One more thing -- if I actually use the Skytrak while keeping it plugged in, the top right of the Skytrak app on my iPad does show the charging icon, and while the 32% holds steady while plugged in and in use, it never goes up.

    Any ideas?
    Last edited by bubbafish; 08-01-2020, 05:31 AM.

  • #2
    Not sure but when you plug it in, does the plug snap in or does it feel loose and pull out easily? My unit is about 2 years old now and it has been recently having issues with charging. The plug is a bit loose so what I do is wrap it around the leg of the FMJ and that gives it enough tension to get the plug connecting.

    if it is a brand new unit though, I would definitely send it back for a replacement.

    Comment


    • #3
      The plug doesn't feel loose, and the yellow light does go on. It must be a defective battery or defective unit. I guess I'll send it in for a replacement.

      Comment

      Working...
      X